Skip to main content

BEST SELLERS

In Networking

Our most popular products, based on sales and updated frequently.
01
Verbatim 8-in-1 USB-C Hub with 4K HDMI Output, USB-C 100W Power Delivery, 2x USB 3.0 Ports, SD+MicroSD Card Reader, 3.5mm Audio
Verbatim 8-in-1 USB-C Hub with 4K HDMI Output, USB-C 100W Power Delivery, 2x USB 3.0 Ports, SD+MicroSD Card Reader, 3.5mm Audio
  • Type: USB / Ethernet
  • Standards: USB 3.0
  • Ports: 2 x USB 3.0 1 x USB C for data 1 x USB C for power 2 x SD card readers 1 x HDMI 1 x 3.5mm audio port
  • Dimensions: 7" x 3.82" x 1"
  • Model #: VUC-2081D
  • Item #: N82E16817130333
  • Return Policy: Standard Return Policy
Save 76%
$14.38
$59.99
Free Shipping

plug'n'play

02
Intel Ethernet Converged Network Adapter X550, Backward compatible 10GBASE-T network adapter | X550T2
Intel Ethernet Converged Network Adapter X550, Backward compatible 10GBASE-T network adapter | X550T2
  • Brand: Intel
  • Part Number: X550-T2
  • Speed: Dual-port 100Mb/s: 3.9 W (Typical Power) 4.9 W (Maximum Power) Dual-port 1GbE 5.5 W (Typical Power) 6.4 W (Maximum Power) Dual-port 10GbE 11.2 W (Typical Power) 13.0 W (Maximum Power)
  • Connectors: 2 x RJ45
  • Model #: X550T2
  • Item #: 9SIADGE9310575
  • Return Policy: View Return Policy
$178.44
$10.99 Shipping

Fast as heck in team mode on Windows Server 2016

03
Teday Wi-Fi 6E Intel AX210 Bluetooth 5.2 + 3000Mbps 2.4Ghz 5Ghz 6Ghz M.2 2230 Key E Desktop Kit Wireless Adapter AX210NGW NGFF WiFi 6 Card 802.11ax/ac MU-MIMO OFDMA Windows 10 With 6Dbi Antenna Set
Teday Wi-Fi 6E Intel AX210 Bluetooth 5.2 + 3000Mbps 2.4Ghz 5Ghz 6Ghz M.2 2230 Key E Desktop Kit Wireless Adapter AX210NGW NGFF WiFi 6 Card 802.11ax/ac MU-MIMO OFDMA Windows 10 With 6Dbi Antenna Set
  • Wireless Data Rates: Speed up to 2400Mbps (The router must support 802.11ax)
  • Frequency Band: 2.4Ghz/5Ghz/6Ghz
  • Type: M.2 Wi-FI Adapter
  • Standards: IEEE 802.11ax/ac
  • Model #: AX210 Kit
  • Item #: 9SIASPTKAP0815
  • Return Policy: View Return Policy
$24.80
Free Shipping

Installed in a few Dell XPS13 laptops, work well. Note: download drivers from Intel

04
TP-Link TL-SM5310-T | 10GBase-T RJ45 SFP+ Module | 10G Copper SFP+ Transceiver | SFP+ to Ethernet | Plug and Play | Hot Pluggable | Up to 30m distance| | Durable Metal Casing | Versatile Compatibility
TP-Link TL-SM5310-T | 10GBase-T RJ45 SFP+ Module | 10G Copper SFP+ Transceiver | SFP+ to Ethernet | Plug and Play | Hot Pluggable | Up to 30m distance| | Durable Metal Casing | Versatile Compatibility
  • Specifications: Standards and Protocols: IEEE Std 802.3, 802.3ab, 802.3bz, 82.3an Power Supply: 3.3V Max. Cable Length: - 100BASE-TX: UTP cat .5 or above (max. 100m) - 1000BASE-T/2.5GBASE-T/5GBASE-T: UTP cat.5e or above (max. 100m) - 10GBASE-T: UTP cat.6a or above (max. 30m) Data Rate: 10.3 Gbps Port Type: 1 x 10G RJ45 Port Safety & Emission: FCC, CE, RoHS Environment: - Operating Temperature: 0 - 70 °C (32 - 158 °F) - Storage Temperature: -40 - 85 °C (-40 - 185 °F)
  • Features: Support 10GBASE-T, 5GBASE-T, 2.5GBASE-T, 1000BASE-T, and 100BASE-TX Transmit data up to 30m* at 10 Gbps (UTP cat.6a or above) Support DDM (Temperature and Voltage) Hot-Pluggable SFP+ Footprint Features Support TX Disable function Commercial Product Operating Temperature Range: 0-70°C Fully Metallic Enclosure for Low EMI
  • Model #: SM5310-T
  • Item #: N82E16833704651
  • Return Policy: Standard Return Policy
$81.99
Free Shipping

Works with my imported TL-SE2106PB. No way to test 10GBE, but now i have 2.5gbe connection between pfsense and switch

05
TP-Link Archer TX20E IEEE 802.11ax AX1800 Wi-Fi 6 Bluetooth 5.2 PCIe Adapter
TP-Link Archer TX20E IEEE 802.11ax AX1800 Wi-Fi 6 Bluetooth 5.2 PCIe Adapter
  • Frequency Band: 2.4 GHz / 5 GHz
  • Standards: IEEE 802.11ax
  • Security: Support 64/128 bit WEP, WPA/WAP2/WPA3, WPA-PSK/WPA2-PSK, 802.1x
  • Modulation: DBPSK, DQPSK, CCK, OFDM, 16-QAM, 64-QAM, 256-QAM, 1024QAM
  • Model #: Archer TX20E
  • Item #: 16R-00EE-00011
  • Return Policy: Standard Return Policy
$34.99
$5.00 Shipping

- Very strong signal compared to my USB adapter. Always full strength on either 2.GHz or 5GHz - Bluetooth connectivity is great - Easy to install

07
Omada ES206XPP-M2 Ethernet Switch
Omada ES206XPP-M2 Ethernet Switch
$199.99
Free Shipping
09
TP-Link PoE Splitter 802.3af Compliant Gigabit Port 5/9/12V DC Power Output Up to 100 meters325 feet TL-PoE10R, Black
TP-Link PoE Splitter 802.3af Compliant Gigabit Port 5/9/12V DC Power Output Up to 100 meters325 feet TL-PoE10R, Black
  • Type: PoE Splitter
  • Color: Black
  • Specifications: Interface: 2 x 10/100/1000Mbps RJ45 Port AUTO Negotiation/AUTO MDI/MDIX 1 x POWER OUTPUT PORT Network Media 10BASE-T: UTP category 3, 4, 5 cable (Max 100m) EIA/TIA-568 100O STP (Max 100m) 100BASE-TX: UTP category 5, 5e cable (Max 100m) EIA/TIA-568 100O STP (Max 100m) 1000BASE-T: UTP category 5, 5e, 6 cable (Max 100m) Power Supply: 12VDC 1A, 9VDC 1A, 5VDC 2A Basic Function: Compatible With IEEE 802.3af Compliant PSEs Delivers Power Up To 100 Meters Optional 12VDC, 9VDC or 5VDC Power Output LED Indicator: PWR Dimensions: 3.2" x 2.0" x 0.9" Certification: FCC, CE, RoHS System Requirements Microsoft Windows 98SE, NT, 2000, XP, Vista or Windows 7, MAC OS, NetWare, UNIX or Linux. Environment Operating Temperature: 0°C - 40°C (32°F - 104°F) Storage Temperature: -40°C - 70°C (-40°F - 158°F) Opera...
  • Model #: TL-POE10R
  • Item #: N82E16833997213
  • Return Policy: 45/1 Return Policy
$19.99
$7.99 Shipping

it is what it says it was, I misordered

10
WAVLINK AC1200 WiFi Range Extender High Power Outdoor Weatherproof Long Range Wireless AP/Wifi Repeater/Router/Signal Booster Dual Band with Passive POE, Gigabit Port, 4x7dBi Detachable Omni Antennas
WAVLINK AC1200 WiFi Range Extender High Power Outdoor Weatherproof Long Range Wireless AP/Wifi Repeater/Router/Signal Booster Dual Band with Passive POE, Gigabit Port, 4x7dBi Detachable Omni Antennas
  • Standards: IEEE 802.11ac, IEEE 802.11a/b/g/n
  • Frequency Band: 2.4 GHz / 5.0 GHz
  • Wireless Data Rates: Up to 1.2Gbps
  • Security: WPA, WPA2
  • Model #: WL-WN572HP3
  • Item #: 9SIC7HJM0A8394
  • Return Policy: View Return Policy
$109.99
Free Shipping

This product really helped me to get a strong signal, which was so important working from home. I used to lose connection often, and now with this product I feel so much more confident.

11
TP-Link JetStream 28-Port Gigabit Smart Switch with 24-Port PoE+ (TL-SG2428P)
TP-Link JetStream 28-Port Gigabit Smart Switch with 24-Port PoE+ (TL-SG2428P)
  • Switch Type: other
  • Format: Desktop
  • Standards: IEEE 802.3i, IEEE 802.3u, IEEE 802.3ab, IEEE802.3z, IEEE 802.3ad, IEEE 802.3x, IEEE 802.3az, IEEE 802.1d, IEEE 802.1s, IEEE 802.1w, IEEE 802.1q, IEEE 802.1p, IEEE 802.1x
  • Primary Ports: 24 x RJ45 + 4 x SFP
  • Model #: SG2428P
  • Item #: 0XP-001U-00667
  • Return Policy: Standard Return Policy
$399.99
$29.99 Shipping
12
StarTech.com N6PATCH30BK Cat6 Patch Cable – 30 ft – Black Ethernet Cable – Snagless RJ45 Cable – Ethernet Cord – Cat 6 Cable – 30ft
StarTech.com N6PATCH30BK Cat6 Patch Cable – 30 ft – Black Ethernet Cable – Snagless RJ45 Cable – Ethernet Cord – Cat 6 Cable – 30ft
  • Brand: StarTech.com
  • Type: Consumer Electronics
  • Cat: 6
  • Connector A: 1 x RJ-45 Male
  • Model #: N6PATCH30BK
  • Item #: N82E16812400956
  • Return Policy: Standard Return Policy
$21.02
$1.99 Shipping

Easy to install

14
3000Mbps Wi-Fi 6E Intel AX210 Bluetooth 5.2 802.11ax/ac 2.4Ghz 5Ghz 6Ghz M.2 2230 Key E Desktop Kit Wireless Adapter AX210NGW NGFF WiFi 6 Card Support MU-MIMO OFDMA Windows 10 With 6Dbi Antenna Set
3000Mbps Wi-Fi 6E Intel AX210 Bluetooth 5.2 802.11ax/ac 2.4Ghz 5Ghz 6Ghz M.2 2230 Key E Desktop Kit Wireless Adapter AX210NGW NGFF WiFi 6 Card Support MU-MIMO OFDMA Windows 10 With 6Dbi Antenna Set
  • Wireless Data Rates: Speed up to 2400Mbps (The router must support 802.11ax)
  • Frequency Band: 2.4Ghz/5Ghz/6Ghz
  • Type: M.2 Wi-FI Adapter
  • Standards: IEEE 802.11ax/ac
  • Model #: WIFI 6E AX210
  • Item #: 9SIC7B7M1R0332
  • Return Policy: View Return Policy
Save 18%
$29.99
$36.99
15
TP-Link Archer TXE72E PCI Express AXE5400 Wi-Fi 6E Bluetooth 5.3 PCIe Adapter
TP-Link Archer TXE72E PCI Express AXE5400 Wi-Fi 6E Bluetooth 5.3 PCIe Adapter
  • Frequency Band: 2.4 GHz / 5 GHz / 6 GHz
  • Standards: IEEE 802.11a/b/g/n/ac/ax
  • Security: WEP, WPA/WPA2/WPA3, WPA-PSK/WPA2-PSK
  • Transmitted Power: 5 GHz: 20dBm(FCC) /15dBm(CE) (EIRP) 2.4 GHz: 20dBm(FCC) / 16dBm(CE) (EIRP) 6 GHz: 12dBm(FCC)
  • Model #: Archer TXE72E
  • Item #: 9SIA9U1KF35850
  • Return Policy: View Return Policy
$95.99
$30.99 Shipping

meets expectations I don't have an AX 5400, but my WAP's AX 3000 works just fine.

16
ASUS RT-BE92U Tri-band WiFi 7 Router, supports new 320MHz bandwidth & 4096-QAM, MLO, AI WAN detection, AiMesh support, subscription-free network security, comprehensive VPN (BE9700)
ASUS RT-BE92UTri-band WiFi 7 Router, supports new 320MHz bandwidth & 4096-QAM, MLO, AI WAN detection, AiMesh support, subscription-free network security, comprehensive VPN (BE9700)
  • Wireless Data Rates: MU-MIMO UTF-8 SSID WiFi MAC Address Filter • Maximum MAC Filters : 64 Wireless Scheduler Airtime Fairness RADIUS Client Universal Beamforming Explicit Beamforming
  • Frequency Band: 2.4 GHz 5 GHz 6 GHz
  • WAN Ports: 1 x 10Gbps for WAN/LAN 1 x 2.5Gbps for WAN/LANInternet Connection Type : • PPPoE • PPTP • L2TP • Automatic IP • Static IP • IPSec Dual WAN 3G / 4G LTE dongle 4G / 5G Auto Mobile Tethering Port forwarding • Maximum Port Forwarding Rule : 64 Port triggering • Maximum Port Triggering Rule : 32 DMZ DDNS NAT Passthrough : • PPTP Pass-Through • L2TP Pass-Through • IPSec Pass-Through • RTSP Pass-Through • H.323 Pass-Through • SIP Pass-Through • PPPoE Relay
  • Brand: ASUS
  • Model #: RT-BE92U
  • Item #: N82E16833320608
  • Return Policy: Standard Return Policy
Save 14%
$299.99
$349.99
$21.00 Shipping

Once setup, the router is excellent, however, I had to have a computer tech friend set it up, and it had its setup and communication difficulties before final operation...I never would have been able to connect the router myself.

17
WiFi 6E Wireless Card Intel AX210 NGW Bluetooth 5.3 Tri-Band 5400Mbps Network Adapter for Laptop Support Windows 10/11 (64bit) M.2/NGFF
WiFi 6E Wireless Card Intel AX210 NGW Bluetooth 5.3 Tri-Band 5400Mbps Network Adapter for Laptop Support Windows 10/11 (64bit) M.2/NGFF
  • Frequency Band: 2.4 GHz / 5 GHz / 6 GHz
  • Interface: PCIe Half Mini Card / M.2 (NGFF)
  • Brand: Intel
  • Model: AX210
  • Model #: AX210.NGWG.NV
  • Item #: 9SIADDZK118002
  • Return Policy: View Return Policy
$35.95
Free Shipping

-Compatible with linux at kernel level. -Fast WiFi and Bluetooth

18
HP Poly ATA 400 VoIP Gateway - 1 x RJ-45 - 1 x FXS - USB - Ethernet | 8F3H4AA
HP Poly ATA 400 VoIP Gateway - 1 x RJ-45 - 1 x FXS - USB - Ethernet | 8F3H4AA
  • Brand: HP
  • Type: Gateway
  • Protocols: LLDP-MED for VLAN discovery; IPv4; TCP (RFC 793) in SSL/TLS; Domain Name System (DNS): A records (RFC 1706), SRV records (RFC 2782), RTP (RFC 1889, 1890), RFC 5966
  • Security: HTTPS secure provisioning; Local Access Interface: IVR password
  • Model #: 8F3H4AA#ABA
  • Item #: 9SIA7BBKHC3015
  • Return Policy: View Return Policy
$181.03
Free Shipping
19
Omada 5-Port 2.5GBASE-T Easy Managed Switch with 1 10GE SFP+ Slot
Omada 5-Port 2.5GBASE-T Easy Managed Switch with 1 10GE SFP+ Slot
$101.99
Free Shipping
20
TP-Link Deco Outdoor Mesh WiFi (Deco X50-Outdoor), AX3000 Dual Band WiFi 6 Mesh, 2 Gigabit PoE Ports, 802.3at PoE+,Weatherproof, Works with All Deco Mesh WiFi
TP-Link Deco Outdoor Mesh WiFi (Deco X50-Outdoor)
$169.99
$8.00 Shipping

The product was quickly shipped by Newegg, received new in box as advertised, and a great price. The installation was very quick using the app and following the step by step instructions, by first setting up the router, then setting up the two other mesh locations. The only time that took long was connecting all the devices to the new WiFi. This eliminated all dead spots, we have full coverage in a 2000 SF home, with all perimeter cameras working flawlessly, and no connection lag with the potential to miss coverage. Highly recommend this product, particularly at this price point of $150 delivered versus $700 to $1000 for wifi 6+ or 7.