
- Screen Size: 27"
- Refresh Rate: 200 Hz
- Resolution: 2560 x 1440 (2K)
- Response Time: 0.5ms (GtG, Min.)
- Model #: MAG 274QF E20
- Item #: N82E16824475580
- Return Policy: Extended Holiday Return Policy

- Screen Size: 34"
- Refresh Rate: 240Hz
- Resolution: 3440 x 1440 (2K)
- Response Time: 1 ms
- Model #: GQ341NE
- Item #: N82E16824942003
- Return Policy: Extended Holiday Return Policy
-Very Wide if you want to work on Video Editing, Graphics Design, or Music - Great and Stable FPS - Does everything thats advertised

- Resolution: 2560 x 1440 (2K)
- Refresh Rate: 75Hz
- Monitor Pixel Density: 0.2331mm
- Display Colors: 16.7 Million
- Model #: 90LM05L1-B013B0
- Item #: 9SIADGEBF38043
- Return Policy: View Return Policy
Super bright. Vivid color. Extremely sharp. No need for adjustment out of the box.

- Resolution: 2560 x 1440 (2K)
- Refresh Rate: 144Hz
- Monitor Pixel Density: 0.2331mm x 0.2331 mm
- Display Colors: 16.7 Million
- Model #: PRO MP273Q E14
- Item #: N82E16824475538
- Return Policy: Extended Holiday Return Policy
Great monitor

- Screen Size: 27"
- Refresh Rate: 200Hz / OC 210Hz
- Resolution: 2560 x 1440
- Response Time: 0.50 ms
- Model #: G27Q20
- Item #: N82E16824012119
- Return Policy: Extended Holiday Return Policy
- stand - overall quality - price

- Screen Size: 24.1"
- Refresh Rate: 360Hz
- Resolution: 2560 x 1440
- Monitor Pixel Density: 0.209mm
- Model #: XQ2566X
- Item #: N82E16824936015
- Return Policy: Extended Holiday Return Policy
Motion clarity. Build quiality/durability.

- Screen Size: 27"
- Refresh Rate: 270Hz
- Resolution: 2560 x 1440 (2K)
- Response Time: 0.50 ms
- Model #: UM.HX0AA.101
- Item #: N82E16824011516
- Return Policy: Extended Holiday Return Policy

- Screen Size: 31.5"
- Refresh Rate: 180Hz
- Response Time: 2ms
- Display Colors: 16.7 Million
- Model #: VX3218C-2K
- Item #: 0JC-0015-008K5
- Return Policy: Extended Holiday Return Policy
Needed to change my old computer screens wich i had bought back in 2012.. choosed to order 2 viewsonic 1440p curved widecreen for gaming and high resolution. They are geat, rsolution is amazing, they are light and i will place them on a hanger for computer screens for my future desk. They are bigger than expected, i am curious to see how they will look on VESA mounting (ypu can do it with rhose screen, but i am curious to see exactly how since they are curved). They provide cables, (power and DP) and the screens also have small speakers (basic ones, but its a plus!) in them. Cant wait so see how they will look once installed. As for the shipping Purolator didnt really delivered them to my door, had to do a 45 minutes trip back and forth to the post office tompick them up, plus, as you can see on pictures, they didnt really took good care of the screens what the hell man! Those are not cereal boxes for kids! I was quite disapointed.. i opened up both boxes, the foam was (lucky me) quite strong and thick, but in one of the box, the foam was crushed down quite a lot. Plugged the two scrren and played a quick video on them to see if they were okay, so far, so good doesnt seems to be broken or scratched or having a dead pixel ( well, for the 4 kinute testing the video in HDR mode..) I dont regret my choice so far, will see how it will goes for gaming and working, but it surely will make a huge difference compared to my 2012 old screens! Go for the 1440p 165ms screen if you have a little extra budget as thet make a huge difference On newegg side, shipping from Ontario to Quebec was quite fast, but a HUGE Thumb down for the delivery guy from Purolator who treated my 2 brand new computer screens like if it was cereal boxes. (And i saw im on my dorbell video also..) otherwise, i recommand this product and the screens are quite large and honestlly very light! 🤙

- Part Number: B100-M102
- Color: Grey
- Material: Mesh
- Frame Material: Steel
- Model #: B100-M102
- Item #: 9SIBZE7KTX7502
- Return Policy: View Return Policy

- Screen Size: 31.5"
- Refresh Rate: 180Hz
- Resolution: 2560 x 1440 (2K)
- Response Time: 1 ms
- Model #: GS32QCA SA1
- Item #: N82E16824012090
- Return Policy: Extended Holiday Return Policy
It worked out of the box, so far so good.

- Model #: PA03810-B055
- Item #: 1SR-0025-000B7
- Return Policy: Extended Holiday Return Policy

- Brand: HP
- Type: Gateway
- Protocols: LLDP-MED for VLAN discovery; IPv4; TCP (RFC 793) in SSL/TLS; Domain Name System (DNS): A records (RFC 1706), SRV records (RFC 2782), RTP (RFC 1889, 1890), RFC 5966
- Security: HTTPS secure provisioning; Local Access Interface: IVR password
- Model #: 8F3H4AA#ABA
- Item #: 9SIA7BBKHC3015
- Return Policy: View Return Policy

- Type: Office Chair
- Color: Black
- Material: Plastic
- Overall Size: 27 x 27 x 51 inches
- Model #: M57-M101
- Item #: 9SIBZE7KK71801
- Return Policy: View Return Policy

- Screen Size: 27"
- Refresh Rate: 280Hz
- Resolution: 2560 x 1440 (2K)
- Response Time: 0.03 ms
- Model #: MO27Q2A SA1
- Item #: N82E16824012107
- Return Policy: Extended Holiday Return Policy

- Brand: UPERFECT
- Cabinet Color: Black
- Screen Size: 21.5"
- Brightness: 350 cd/m2
- Model #: M215E02W
- Item #: 9SIBZF8KEH4648
- Return Policy: View Return Policy

- Model #: DS2278-SR7U2100PRW-2485898
- Item #: 9SIBTD7KEP0064
- Return Policy: View Return Policy

- Brand: ASUS
- Cabinet Color: Black
- Screen Size: 15.6"
- Resolution: 1920 x 1080
- Model #: MB169CK
- Item #: N82E16824281359
- Return Policy: Extended Holiday Return Policy
- Great price - lightweight, portable - comes with a sleeve

- Screen Size: 34"
- Refresh Rate: 280Hz
- Resolution: 3440 x 1440
- Response Time: 0.03ms(GTG)
- Model #: XG34WCDMS
- Item #: N82E16824281427
- Return Policy: Extended Holiday Return Policy
This monitor is insane! Rgb stripe layout fixes text clarity for people who had that issue. Blacks are abyss black. Colors and brightness are even better than on my pg32ucdm3. I pulled it out the box put on monitor arm and colors and everything is at factory defaults and it looks incredible!

- Screen Size: 27"
- Refresh Rate: 240Hz
- Resolution: 1920 x 1080
- Response Time: 0.50 ms
- Model #: MAG 274CF X24
- Item #: N82E16824475522
- Return Policy: Extended Holiday Return Policy
They work well and easy to set up as a triple monitor set up for a sim rig

- Resolution: 2560 x 1440 (2K)
- Refresh Rate: 144Hz
- Monitor Pixel Density: 0.2331mm x 0.2331 mm
- Display Colors: 16.7 Million
- Model #: PRO MP273QW E14
- Item #: N82E16824475539
- Return Policy: Extended Holiday Return Policy
We have this white MSI PRO MP273QW E14 for our front desk to match with our white setup and the color perfectly matches. Main reason to pick this monitor is that it offers more than other brands on eye care, which is really crucial. It has TÜV-certified low blue light, anti-flicker tech, and MSIs Eye-Q Check to help reduce eye strain during long sessions.