Skip to main content
HP
  • Shop All HP Products At Newegg

  • Our vision is to create technology that makes life better for everyone, everywhere — every person, every organization, and every community around the globe. This motivates us — inspires us — to do what we do. To make what we make. To invent, and to reinvent. To engineer experiences that amaze. We won’t stop pushing ahead, because you won’t stop pushing ahead. You’re reinventing how you work. How you play. How you live. With our technology, you’ll reinvent your world. This is our calling. This is a new HP. Keep reinventing. See More
All Products
About HP
Sort By
7,151 Items
View
  1. 1 / 20
HP Poly ATA 400 VoIP Gateway - 1 x RJ-45 - 1 x FXS - USB - Ethernet | 8F3H4AA
01
Best Seller
in VoIP
HP Poly ATA 400 VoIP Gateway - 1 x RJ-45 - 1 x FXS - USB - Ethernet | 8F3H4AA
  • Brand: HP
  • Type: Gateway
  • Protocols: LLDP-MED for VLAN discovery; IPv4; TCP (RFC 793) in SSL/TLS; Domain Name System (DNS): A records (RFC 1706), SRV records (RFC 2782), RTP (RFC 1889, 1890), RFC 5966
  • Security: HTTPS secure provisioning; Local Access Interface: IVR password
  • Model #: 8F3H4AA#ABA
  • Item #: 9SIA7BBKHC3015
  • Return Policy: View Return Policy
$191.18
Free Shipping
HP ProDesk 600 G4 Desktop Mini Business PC Intel Core i5-8500T 8th Gen Processor 8GB RAM 256GB SSD Windows 11 Pro - New 27 inch Monitor
Refurbished: HP ProDesk 600 G4 Desktop Mini Business PC Intel Core i5-8500T 8th Gen Processor 8GB RAM 256GB SSD Windows 11 Pro - New 27 inch Monitor
  • Type: Business Desktops & Workstations
  • Form Factor: Mini PC
  • Color: Black/Silver
  • Ethernet: Ethernet
  • Model #: H600G4TYI5816G256S-27"
  • Item #: 9SIAK3KK0Y7351
  • Return Policy: View Return Policy
$419.99
Free Shipping
HP USB-C 100W G6 Dock 9X3V1U 9X3V1UTABA
HP USB-C 100W G6 Dock 9X3V1U 9X3V1UTABA
$211.11
$10.99 Shipping
Poly Voyager 4310 Microsoft Teams Certified Headset +BT700 dongle +Charging Stand (77Y93AA)
Poly Voyager 4310 Microsoft Teams Certified Headset +BT700 dongle +Charging Stand (77Y93AA)
  • Features: Poly Voyager 4310-M Microsoft Teams Certified Headset with charge stand
  • Brand: HP
  • Part Number: 77Y93AA
  • Type: Wired with Bluetooth Wireless
  • Model #: 77Y93AA
  • Return Policy: View Return Policy
$207.22
$10.99 Shipping
HP EliteBook 830 G8 13.3" Notebook, i7-1185G7, 16GB DDR4-3200, 512GB M.2 PCIe NVMe SSD
Refurbished: HP EliteBook 830 G8 13.3" Notebook, i7-1185G7, 16GB DDR4-3200, 512GB M.2 PCIe NVMe SSD
  • Processor Name: i7-1185G7
  • GPU/VPU: Onboard
  • Memory: 160GB DDR4
  • SSD: 512GB NVMe
  • Model #: ELITEBOOK 830 G8
  • Item #: 9SIC6FSM6M8784
  • Return Policy: View Return Policy
$425.00
$45.00 Shipping
HP LaserJet Pro 4001dn Laser Printer, Black And White Mobile Print Up to 80,000
HP LaserJet Pro 4001dn Laser Printer, Black And White Mobile Print Up to 80,000
  • Recommended Use: MFC / All-In-One
  • Output Capacity, std.: 250 pages
  • Black Print Speed: Prints up to 42/40 ppm (LTR/A4)
  • Black Print Quality: 1200 x 1200 dpi
  • Model #: 2Z600F#BGJ
  • Return Policy: View Return Policy
$1,046.46
Free Shipping
HP OmniBook 3 16.0" Qualcomm Snapdragon X X1-26-100 16GB DDR5 Memory LPDDR5x-8448 256GB NVMe SSD Windows 11 Home 16-bz0010ca
HP OmniBook 3 16.0" Qualcomm Snapdragon X X1-26-100 16GB DDR5 Memory LPDDR5x-8448 256GB NVMe SSD Windows 11 Home 16-bz0010ca
  • Processor Name: Qualcomm Snapdragon X X1-26-100
  • Memory: 16GB DDR5
  • SSD: 256GB NVMe
  • GPU/VPU: Integrated Graphics
  • Model #: D62ZTUA#ABL
  • Item #: N82E16834818513
  • Return Policy: Extended Holiday Return Policy
Save 33%
$999.99
$1,499.99
$15.00 Shipping
HP Elite Mini 800 G9 Mini Desktop PC, Intel Core i7-14700T, 32GB DDR5, 512GB SSD, Windows 11 Pro (A12GVUT#ABA)
HP Elite Mini 800 G9 Mini Desktop PC, Intel Core i7-14700T, 32GB DDR5, 512GB SSD, Windows 11 Pro (A12GVUT#ABA)
  • Type: Student / Home Office
  • CPU Name: Intel Core i7-14700T
  • GPU/VGA Type: Intel UHD Graphics 770
  • Memory Capacity: 32GB DDR5
  • Model #: A12GVUT#ABA
  • Item #: 9SIADGEKE00870
  • Return Policy: View Return Policy
$1,899.99
$20.38 Shipping
HP 14-em0085cl 14" HD Laptop AMD Ryzen 7 7730U 32GB Memory 1 TB NVMe SSD Windows 11 Home AMD Radeon Graphics
HP 14-em0085cl 14" HD Laptop AMD Ryzen 7 7730U 32GB Memory 1 TB NVMe SSD Windows 11 Home AMD Radeon Graphics
  • Processor Name: AMD Ryzen 7 7730U
  • Memory: 32GB
  • SSD: 1TB NVMe
  • GPU/VPU: AMD Radeon Graphics
  • Model #: B43BVUA#ABA
  • Item #: N82E16834818277
  • Return Policy: Extended Holiday Return Policy
Save 25%
$889.99
$1,199.99
$31.78 Shipping
HP Poly Audio Cable - 7 ft Audio Cable for Headset, Amplifier Model 85S07AA
HP ProBook 4 G1i 16" Notebook - Intel Core Ultra 7 255U - 16GB - 512GB SSD - Pike Silver - Windows 11 Pro - Webcam - 13.25 Hours Battery Run Time - IEEE 802.11ax Wireless   BB3R1UT#ABA
HP ProBook 4 G1i 16" Notebook - Intel Core Ultra 7 255U - 16GB - 512GB SSD - Pike Silver - Windows 11 Pro - Webcam - 13.25 Hours Battery Run Time - IEEE 802.11ax Wireless BB3R1UT#ABA
  • Processor Name: Intel Core Ultra 7 255U
  • Type: Home / Personal
  • Resolution: 1920 x 1200
  • Brand: HP
  • Model #: BB3R1UT#ABA
  • Return Policy: View Return Policy
$1,899.99
$20.38 Shipping
HyperX Mechanical Gaming Keyboard HX Aqua US Layout 4P5D6AA
HyperX Mechanical Gaming Keyboard HX Aqua US Layout 4P5D6AA
  • Brand: HyperX
  • Keyboard Interface: USB 2.0
  • Design Style: Standard
  • Layout: 65%
  • Model #: 4P5D6AA#ABA
  • Item #: 0GA-01DC-000X2
  • Return Policy: Extended Holiday Return Policy
Save 28%
$99.99
$139.99
Free Shipping
HP OmniBook X Flip 2-in-1 16" 2K Touchscreen Laptop, Intel Ultra 9 288V, 32GB LPDDR5X, 2TB Storage (1TB SSD+1TB Docking Station), Intel Arc 140V, Backlit Keyboard, Copilot+ PC, Win 11 Pro, Gray
HP OmniBook X Flip 2-in-1 16" 2K Touchscreen Laptop, Intel Ultra 9 288V, 32GB LPDDR5X, 2TB Storage (1TB SSD+1TB Docking Station), Intel Arc 140V, Backlit Keyboard, Copilot+ PC, Win 11 Pro, Gray
  • Processor Name: Intel Core Ultra 9 288V
  • Memory: 32GB DDR5
  • SSD: 1TB
  • GPU/VPU: Intel Arc 140V
  • Model #: 199896888967_32_1_NEx_p_L1
  • Return Policy: View Return Policy
$2,699.00
HP OmniBook 3 16.0" Intel Core 3 100U 8GB Memory DDR5 5200 256GB NVMe SSD Windows 11 Home 16-bu0060ca
HP OmniBook 3 16.0" Intel Core 3 100U 8GB Memory DDR5 5200 256GB NVMe SSD Windows 11 Home 16-bu0060ca
  • Processor Name: Intel Core 3 100U
  • Memory: 8GB
  • SSD: 256GB NVMe
  • GPU/VPU: Intel Graphics
  • Model #: D62ZPUA#ABL
  • Item #: N82E16834818511
  • Return Policy: Extended Holiday Return Policy
Save 27%
$799.99
$1,099.99
$15.00 Shipping
HP OmniBook 3 Notebook 14" WUXGA OLED Qualcomm Snapdragon X X1-26100 32GB 1TB  Windows 11 Home
01
Best Seller
in Chromebook
HP OmniBook 3 Notebook 14" WUXGA OLED Qualcomm Snapdragon X X1-26100 32GB 1TB Windows 11 Home
  • Screen Size: 14"
  • Brand: HP
  • Type: Notebooks
  • Model #: D4AC1UA#ABL
  • Return Policy: View Return Policy
$1,248.00
Free Shipping
781417-001 BU40N S05JH HP UHD 6X BLU-RAY/DVD Writer 9.5MM Optical Disk Drive 762434-800 USA Blu-Ray Drives
HP USB-C 65W Laptop Charger
HP USB-C 65W Laptop Charger
  • Brand: HP
  • Part Number: 671R3UT#ABA
  • Type: Laptop Chargers\Adapters
  • Battery Type: Laptop Chargers\Adapters
  • Model #: 671R3UTABA
  • Return Policy: View Return Policy
$44.69
Free Shipping
HP ZGX Nano G1n AI Station - Nvidia GB10 Processor - 128GB -  4TB SSD - NVIDIA Blackwell GPU - Gigabit Ethernet - Wi-Fi 7 - BT 5.4  (CZ2V8UT#ABA) - OEM
HP ZGX Nano G1n AI Station - Nvidia GB10 Processor - 128GB - 4TB SSD - NVIDIA Blackwell GPU - Gigabit Ethernet - Wi-Fi 7 - BT 5.4 (CZ2V8UT#ABA) - OEM
  • Brand: HP
  • Part Number: CZ2V8UT#ABA
  • Type: Mini PC
  • CPU Type: Nvida GB10 Processor
  • Model #: CZ2V8UT#ABA
  • Item #: N82E16859099033
  • Return Policy: Extended Holiday Return Policy
$10,899.00
Free Shipping