Your Browsing History
- In Stock
- Sold by Newegg
- New

Quick View
Cisco Catalyst C1200-24FP-4X Ethernet Switch, 24 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
- Part Number: C1200-24FP-4X
- Switch Type: Manageable
- Format: Rack-mountable
- Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1p IEEE 802.11ac IEEE 802.1Q IEEE 802.1ab
- Model #: C1200-24FP-4X
- $1,876.99 –

Quick View
Cisco Catalyst C1300-16P-2G Ethernet Switch, 16 Ports - Manageable - Gigabit Ethernet - 1000Base-X, 10/100/1000Base-T - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-16P-2G
- Format: Rail-mountable
- Model #: C1300-16P-2G
- $1,478.74 –
- Free Shipping

Quick View
Cisco Catalyst 1300 C1300-8MGP-2X Layer 3 Switch, 8 Ports - Manageable - Gigabit Ethernet, 2.5 Gigabit Ethernet, 10 Gigabit Ethernet - 10/100/1000Base-T, 2.5GBase-T, 10GBase-X - 3 Layer Supported
- Part Number: C1300-8MGP-2X
- Format: Rack-mountable
- Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3ae IEEE 802.3an IEEE 802.3x IEEE 802.1D IEEE 802.1Q IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1ab
- Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet 2.5 Gigabit Ethernet 10 Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 2.5GBase-T 10GBase-X Maximum Data Transfer Rate: 1.25 GB/s
- Model #: C1300-8MGP-2X
- $1,770.99 –

Quick View
Cisco CBS220-48FP-4X Smart Switch | 48 Port GE | Full PoE | 4x10G SFP+ | 3-Year Limited Hardware Warranty (CBS220-48FP-4X-NA)
- Brand: Cisco Systems, Inc
- Series: Business
- Part Number: CBS220-48FP-4X-NA
- Switch Type: managed
- Model #: CBS220-48FP-4X
- $3,033.99 –

Quick View
Cisco Catalyst C1200-24FP-4G Ethernet Switch, 24 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
- Part Number: C1200-24FP-4G
- Format: Rack-mountable
- Standards: Layer Supported: 3 Networking Standards: IEEE 802.11ac IEEE 802.1x IEEE 802.3az IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3ad IEEE 802.1Q IEEE 802.1p IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.3af IEEE 802.3at
- Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 1000Base-X
- Model #: C1200-24FP-4G
- $1,671.60 –
- Free Shipping

Quick View
Cisco Catalyst 1300 Managed Switch, 16 Port GE, 8 Port 2.5GE, PoE, 4x10GE SFP+, Limited Lifetime Protection Model | C1300-24MGP-4X
- Brand: Cisco Systems, Inc.
- Series: Catalyst C1300 Series
- Part Number: C1300-24MGP-4X
- Standards: IEEE 802.3 10BASE-T Ethernet, IEEE 802.3u 100BASE-TX Fast Ethernet, IEEE 802.3ab 1000BASE-T Gigabit Ethernet, IEEE 802.3ad Link Aggregation Control Protocol, IEEE 802.3z Gigabit Ethernet, IEEE 802.3ae 10 Gbps Ethernet over fiber for LAN, IEEE 802.3an 10GBASE-T 10 Gbps Ethernet over copper twisted pair cable, IEEE 802.3x Flow Control, IEEE 802.1D (STP, GARP, and GVRP), IEEE 802.1Q/p VLAN, IEEE 802.1w Rapid STP, IEEE 802.1s Multiple STP, IEEE 802.1X Port Access Authentication, IEEE 802.3af, IEEE 802.3at, IEEE 802.1AB Link Layer Discovery Protocol, IEEE 802.3az Energy Efficient Ethernet, RFC 768, RFC 783, RFC 791, RFC 792, RFC 793, RFC 813, RFC 826, RFC 879, RFC 896, RFC 854, RFC 855, RFC 856, RFC 858, RFC 894, RFC 919, RFC 920, RFC 922, RFC 950, RF...
- Model #: C1300-24MGP-4X
- $3,227.99 –

Quick View
Cisco Catalyst C1300-48T-4G Ethernet Switch, 54 Ports - Manageable - Gigabit Ethernet - 1000Base-X, 10/100/1000Base-T - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-48T-4G
- Format: Rack-mountable
- Model #: C1300-48T-4G
- $2,141.99 –

Quick View
Cisco Catalyst C1200-48P-4X Ethernet Switch, 48 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
- Part Number: C1200-48P-4X
- Switch Type: Manageable
- Format: Rack-mountable
- Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1p IEEE 802.11ac IEEE 802.1Q IEEE 802.1ab
- Model #: C1200-48P-4X
- $1,883.99 –

Quick View
Cisco Catalyst C1300-16FP-2G Ethernet Switch, 16 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-16FP-2G
- Format: Rack-mountable
- Model #: C1300-16FP-2G
- $2,373.99 –

Quick View
Cisco Catalyst 1300-12XS Managed Switch, 10 Port 10G SFP+, 2x10GE SFP+ Combo, Limited Lifetime Protection (C1300-12XS)
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-12XS
- Switch Type: Manageable
- Model #: C1300-12XS
- $3,384.99 –

Quick View
Cisco Catalyst 9200L 24-port PoE+ 4x1G uplink Switch, Network Essentials | C9200L-24P-4G-E
- Brand: CISCO
- Series: 9200
- Network Management Type: Managed
- Primary Port Speed: 1000Base-X 10/100/1000Base-T
- Model #: C9200L-24P-4G-E
- $3,916.99 –

Quick View
Cisco Catalyst C9300-48UXM-E Ethernet Switch
- Format: Rack-mountable
- Primary Port Speed: 10/100/1000Base-T
- Weight: 17.03 lb
- Model #: C9300-48UXM-E
- $27,604.99 –

Quick View
Cisco Catalyst 1300 C1300-24XTS Layer 3 Switch, 12 Ports - Manageable - 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-24XTS
- Format: Rack-mountable
- Model #: C1300-24XTS
- $7,370.99 –

Quick View
Cisco Catalyst C1300-48P-4X Ethernet Switch, 48 Ports - Manageable - 10 Gigabit Ethernet - 10/100/1000Base-T, 10GBase-X - 3 Layer Supported
- Part Number: C1300-48P-4X
- Format: Rackmount
- Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3x IEEE 802.1D IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1p IEEE 802.11ac IEEE 802.1Q IEEE 802.1ab
- Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: 10 Gigabit Ethernet Network Technology: 10/100/ 1000Base-T 10GBase-X
- Model #: C1300-48P-4X
- $4,028.99 –

Quick View
Cisco Catalyst 9200L 24-port PoE+ 4x10G uplink Switch, Network Essentials | C9200L-24P-4X-E
- Brand: Cisco
- Series: 9200
- Network Management Type: Managed
- Primary Port Speed: 10GBase-X 10/100/1000Base-T
- Model #: C9200L-24P-4X-E
- $5,591.99 –
- Free Shipping

Quick View
Cisco Catalyst C1300 managed Layer 3 Switch, 48x 10/100/1000 30W PoE+ ports w/ 370W power budget, 4 x Gigabit SFP, Rack-mountable | C1300-48P-4G
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-48P-4G
- Format: Rackmount
- Model #: C1300-48P-4G
- $2,978.16 –
- Free Shipping

Quick View
Cisco Catalyst C1300-16XTS Layer 3 Switch, 8 Ports - Manageable - 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 3 Layer Supported
- Part Number: C1300-16XTS
- Format: Rack-mountable
- Standards: Layer Supported: 3 Networking Standards: IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3ad IEEE 802.3z IEEE 802.3ae IEEE 802.3an IEEE 802.3x IEEE 802.1D IEEE 802.1Q IEEE 802.1p IEEE 802.1w IEEE 802.1x IEEE 802.3af IEEE 802.3at IEEE 802.1ab IEEE 802.3az
- Network Media: Media Type Supported: Optical Fiber Twisted Pair Ethernet Technology: 10 Gigabit Ethernet Network Technology: 10GBase-T 10GBase-X Maximum Data Transfer Rate: 1.25 GB/s
- Model #: C1300-16XTS
- $5,687.99 –

Quick View
Cisco Catalyst 1300 C1300-24XT Layer 3 Switch, 20 Ports - Manageable - Gigabit Ethernet, 10 Gigabit Ethernet - 10GBase-T, 10GBase-X - 3 Layer Supported
- Part Number: C1300-24XT
- Format: Rack-mountable
- Standards: Layer Supported: 3 Networking Standards: IEEE 802.1x IEEE 802.3az IEEE 802.3ad IEEE 802.3 IEEE 802.3u IEEE 802.3ab IEEE 802.3z IEEE 802.3ae IEEE 802.3an IEEE 802.3x IEEE 802.1D IEEE 802.1Q IEEE 802.1p IEEE 802.1w IEEE 802.1s IEEE 802.3af IEEE 802.3at IEEE 802.1ab
- Network Media: Media Type Supported: Twisted Pair Optical Fiber Ethernet Technology: Gigabit Ethernet 10 Gigabit Ethernet Network Technology: 10GBase-T 10GBase-X Maximum Data Transfer Rate: 1.25 GB/s
- Model #: C1300-24XT
- $6,973.99 –

Quick View
Cisco Catalyst C1300-48FP-4G Ethernet Switch, 48 Ports - Manageable - Gigabit Ethernet - 10/100/1000Base-T, 1000Base-X - 3 Layer Supported
- Brand: Cisco Systems, Inc
- Series: Catalyst
- Part Number: C1300-48FP-4G
- Format: Rackmount
- Model #: C1300-48FP-4G
- $3,806.31 –
- Free Shipping

Quick View
Cisco Catalyst 9200L 48-port PoE+ 4x10G uplink Switch, Network Essentials | C9200L-48P-4X-E
- Brand: Cisco
- Series: 9200
- Part Number: C9200L-48P-4X
- Network Management Type: Managed
- Model #: C9200L-48P-4X-E
- $11,355.99 –

Quick View
Cisco Catalyst 9200L 48-port Data 4x1G uplink Switch, Network Essentials | C9200L-48T-4G-E
- Brand: CISCO
- Series: 9200
- Part Number: C9200L-48T-4G
- Format: Rackmount
- Model #: C9200L-48T-4G-E
- $6,045.99 –

Quick View
Cisco Catalyst C1300-48MGP-4X, 48-port Layer 3 Managed Switch | C1300-48MGP-4X
- Brand: Cisco Systems, Inc.
- Series: Catalyst 1300 Series
- Part Number: C1300-48MGP-4X
- Format: Rackmount
- Model #: C1300-48MGP-4X
- $5,496.99 –

Quick View
Cisco Catalyst 9300 24-port data only, Network Essentials
- Primary Port Speed: 10/100/1000Base-T
- Weight: 16.03 lb
- Parts: Lifetime
- Model #: C9300-24T-E
- $12,194.99 –

Quick View
Cisco Catalyst 9300 24-port PoE+, Network Advantage
- Primary Port Speed: 10/100/1000Base-T
- Protocols: TCP/IP
- Weight: 16.33 lb
- Model #: C9300-24P-A
- $12,953.99 –

Quick View
Cisco Catalyst 9300 48-port PoE+ Ethernet Switch C9300-48P-E
- Primary Port Speed: 10/100/1000Base-T
- Protocols: TCP/IP
- Weight: 16.73 lb
- Parts: Lifetime
- Model #: C9300-48P-E
- $22,308.99 –

Quick View
Cisco Business CBS220-24FP-4X Ethernet Switch CBS22024FP4XNA
- Switch Type: ethernet
- Model #: CBS22024FP4XNA
- $2,097.99 –

Quick View
Cisco Catalyst 9300 Network Essentials switch 48 ports managed rack-mountable
- Model #: C9300-48UN-E#
- $26,263.99 –

Quick View
Cisco Catalyst 9300 Network Essentials switch 24 ports managed rack-mountable
- Model #: C9300-24S-E#
- $51,104.99 –

Quick View
CISCO IE-3200-8T2S-E Managed Catalyst IE3200 w/ 8 GE Copper and 2 GE SFP, Fixed System, Network Essentials
- Format: DIN Rail Mount
- Standards: IEEE 802.3, IEEE 802.3u, IEEE 802.3z, IEEE 802.1D, IEEE 802.1Q, IEEE 802.3ab, IEEE 802.1p, IEEE 802.3x, IEEE 802.3ad (LACP), IEEE 802.1w, IEEE 802.1x, IEEE 802.1s, IEEE 802.3ah, IEEE 802.1ab (LLDP), IEEE 1588v2
- Primary Ports: 8 x RJ45 + 2 x SFP
- Primary Port Speed: 10/100/1000Mbps
- Model #: IE-3200-8T2S-E
- $7,212.99 –

Quick View
Cisco Catalyst C9200L-48T-4X Layer 3 Switch - 48 X Gigabit Ethernet Network, 4 X 10 Gigabit Ethernet Uplink - Manageable - Twisted Pair, Optical Fiber - Modular - 3 Layer Supported - Rack-Mountable
- Format: Rack-mountable
- Primary Port Speed: 10GBase-X 10/100/1000Base-T
- Protocols: TCP/IP
- Weight: 11.02 lb
- Model #: C9200L-48T-4X-E
- $7,469.99 –

Quick View
Cisco Catalyst IE-3300-8P2S Rugged Switch
- Format: DIN Rail Mountable
- Primary Port Speed: 1000Base-X 10/100/1000Base-T
- Weight: 3.75 lb
- Parts: 5 Year
- Model #: IE-3300-8P2S-E
- $17,009.99 –

Quick View
Cisco Catalyst 9300 48-port UPOE, Network Essentials
- Primary Port Speed: 10/100/1000Base-T
- Weight: 17.03 lb
- Model #: C9300-48U-E
- $27,341.99 –

Quick View
Cisco Catalyst 9300 24-port Data Only, Network Essentials
- Primary Port Speed: 10/100/1000Base-T
- Protocols: TCP/IP
- Weight: 16.03 lb
- Model #: C9300-24T-A
- $12,762.99 –

Quick View
Cisco Catalyst 9200 C9200L-24T-4X Layer 3 Switch
- Primary Port Speed: 10GBase-X 10/100/1000Base-T
- Model #: C9200L-24T-4X-E
- $6,768.99 –

Quick View
Cisco Catalyst C9200-24T Layer 3 Switch
- Primary Port Speed: 10/100/1000Base-T
- Weight: 9.59 lb
- Model #: C9200-24T-E
- $6,899.99 –
