Skip to main content

Best Sellers

Newegg
  • $154.99
  • + FREE SHIPPING
Shop it at NeweggBusiness.

Yealink SIP-T34W Entry-level IP Phone with 4 Lines & Color LCD

  • Built-in dual band 2.4G/5G Wi-Fi (802.11a/b/g/n/ac)
  • USB 2.0 port for wired USB headsets/Bluetooth headsets
  • Yealink HD Voice
  • 2.4" 320 x 240-pixel color display with backlight
  • Dual-port Gigabit Ethernet
  • PoE support
  • Up to 4 SIP accounts
  • Local 5-way conferencing
  • Support EHS Wireless Headset
  • Unified Firmware
  • Support YDMP/YMCS
  • Stand with 2 adjustable angles
  • Wall mountable
  • Handset with hall switch
+
+
Specs
Reviews

Learn more about the Yealink Network Technology Co., Ltd SIP-T34W

Model
Brand Yealink
Model SIP-T34W
Part Number SIP-T34W
Type
Type VoIP Phones
Spec
Security NETWORK AND SECURITY

SIP v1 (RFC2543), v2 (RFC3261)
Call server redundancy supported
NAT traversal: STUN mode
Proxy mode and peer-to-peer SIP link mode
IP assignment: static/DHCP
HTTP/HTTPS web server
Time and date synchronization using SNTP
UDP/TCP/DNS-SRV (RFC 3263)
QoS: 802.1p/Q tagging (VLAN), Layer 3 ToS DSCP
SRTP for voice
Transport Layer Security (TLS 1.3)
HTTPS certificate manager
AES encryption for configuration file (AES256)
Digest authentication
OpenVPN, IEEE802.1X, L2TP VPN
IPv6
LLDP/CDP/DHCP VLAN
ICE
• WPA2/WPA3
• Secure boot
• GARP (Generic Attribute Registration Protocol)
Ports Dual-port Gigabit Ethernet
Power over Ethernet (IEEE 802.3af), class 2
1 x RJ9 (4P4C) handset port
1 x RJ9 (4P4C) headset port
Display DISPLAY AND INDICATOR

2.4" 320 x 240-pixel color display with backlight
16 bit depth color
LED for call and message waiting indication
Dual-color (red or green) illuminated LEDs for line status information
Wallpaper
Intuitive user interface with icons and soft keys
Multilingual user interface
Caller ID with name and number
Screensaver
Power saving
Power External Yealink AC adapter AC 100-240 V input and DC 5 V/1.2 A output
Power consumption (PSU): 1.65-2.94 W
Power consumption (PoE): 2.33-3.35 W
Dimensions Dimension (W x D x H x T): 212 x 186 x 146 x 42 mm
Features
Features PHONE

4 VoIP accounts
Call hold, mute, DND
One-touch speed dial, hotline
Call forward, call waiting, call transfer
Group listening, SMS, emergency call
Redial, call return, auto answer
Local 5-way conferencing
Direct IP call without SIP proxy
Ring tone selection/import/delete
Set date time manually or automatically
Dial plan
XML Browser, action URL/URI
Integrated screenshots
RTCP-XR, VQ-RTCPXR
Built-in dual band Wi-Fi
USB port (2.0 compliant) for: Yealink wired/Bluetooth headsets
Enhanced DSS Key

AUDIO

HD voice: HD handset, HD speaker
Smart Noise Filtering
Wideband codec: G.722
Narrowband codec: PCMU (G.711µ), PCMA (G.711A), G.723.1, G.729, G.729A, G.729B, G.729AB, G.726, iLBC
DTMF: In-band, Out-of-band (RFC 2833) and SIP INFO
Full-duplex hands-free speakerphone with AEC
VAD, CNG, AEC, PLC, AJB, AGC

DIRECTORY

Local phonebook up to 1000 entries
Blocklist
XML/LDAP remote phonebook
Smart dialing
Phonebook search/import/export
Call history: dialed/received/missed/forwarded
Additional Information
First Listed on Newegg June 05, 2025

Warranty & Returns

Warranty, Returns, And Additional Information

Warranty

  • Please contact the Seller directly for warranty information. Warranty information may also be found on the Manufacturer's website.
  • Read full details
  • CONTACT

Return Policies

Manufacturer Contact Info

LOADING...
LOADING...